WebTrader Platform: Flash Player Required

July 17, 2014

I can’t access WebTrader. What are my options?

In order to use the Vantage FX WebTrader platform, please make ensure you have the following:

  • Adobe Flash Player
  • Google Chrome, Firefox, Internet Explorer, Safari, or Opera browser
  • A live internet connection

Use the link below to install Adobe® Flash® Player:

160x41_get_flashplayer
Get Adobe® Flash® Player

Alternative options

If you are unable to meet the above requirements, please find a list of Vantage FX trading platform alternatives below:

Social

Free Daily Market Update

Live Spreads

SymbolBidAskSpread

Spread

Sign up to the latest forex news and daily FX trading setups

Get started with a FREE $50,000 demo account